pku 3363(内部测试赛)

Annoying painting tool

Time Limit: 1000MS Memory limit: 65536K

题目描述

Maybe you wonder what an annoying painting tool is? First of all, the painting tool we speak of supports only black and white. Therefore, a picture consists of a rectangular area of pixels, which are either black or white. Second, there is only one operation how to change the colour of pixels:

Select a rectangular area of r rows and c columns of pixels, which is completely inside the picture. As a result of the operation, each pixel inside the selected rectangle changes its colour (from black to white, or from white to black).

Initially, all pixels are white. To create a picture, the operation described above can be applied several times. Can you paint a certain picture which you have in mind?

输入

The input contains several test cases. Each test case starts with one line containing four integers n, m, r and c. (1 ≤ r ≤ n ≤ 100, 1 ≤ c ≤ m ≤ 100), The following nlines each describe one row of pixels of the painting you want to create. The ith line consists of m characters describing the desired pixel values of the ith row in the finished painting (\'0\' indicates white, \'1\' indicates black).

The last test case is followed by a line containing four zeros.

输出

For each test case, print the minimum number of operations needed to create the painting, or -1 if it is impossible.

示例输入

3 3 1 1

010

101

010

4 3 2 1

011

110

011

110

3 4 2 2

0110

0111

0000

0 0 0 0

示例输出

4

6

-1
 
   
将每一个1看成小矩形的左上角  ,每一个点(左上角)只能被反转一次



#include<stdio.h>

#define N 150

char map[N][N];

int main()

{

    int n,m,r,c,i,j,k,l;

    while(scanf("%d%d%d%d",&n,&m,&r,&c),n+m+r+c)

    {

        int num=0;

        getchar();

        int f=0;

        for(i=0;i<n;i++)scanf("%s",map[i]);

        for(i=0;i<n;i++)

        {

            for(j=0;j<m;j++)

            {

                if(map[i][j]=='1')

                {

                    if(i+r-1>=n||j+c-1>=m)break;

                    num++;

                    for(k=i;k<i+r;k++)

                    {

                        for(l=j;l<j+c;l++)

                        {

                            if(map[k][l]=='1')map[k][l]='0';

                            else map[k][l]='1';

                        }

                    }

                }

            }

            if(j<m)f=1;

        }

        if(f)printf("-1\n");

        else

        printf("%d\n",num);

    }

}

  

你可能感兴趣的:(pku)