ACM学习历程—HDU 1272 小希的迷宫(并查集)

Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房 间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走 了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从 5到达8。
 

Input

输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
 

Output

对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
 

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
 
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
 
3 8 6 8 6 4
5 3 5 6 5 2 0 0
 
-1 -1
 

Sample Output

Yes
Yes
No

 

就是并查集,形成环路的只需要判断是否有相同的根,通过set集合得到点的数目,然后与合并次数相减,如果不是1,说明是森林。

这里使用递归压缩路径会爆栈,需要使用非递归的。

此外,对于0 0这组没有意义的数,需要输出Yes。。。。。

 

代码:

#include <iostream>

#include <cstdio>

#include <cstdlib>

#include <cstring>

#include <cmath>

#include <set>

#include <map>

#include <queue>

#include <string>

#include <algorithm>

#define LL long long



using namespace std;



bool ans;

int ufs[100005], num;

set<int> s;



/*

int findRoot(int x)

{

    int fa = ufs[x];

    if (fa == 0)

        return x;

    ufs[x] = findRoot(fa);

    return ufs[x];

}

*/



int findRoot(int x)

{

    int pre, now, rx;

    rx = x;

    while(ufs[rx] != 0)

        rx = ufs[rx];

    pre = x;

    while(pre != rx)

    {

        now = ufs[pre];

        ufs[pre] = rx;

        pre = now;

    }

    return rx;

}



bool mergeUfs(int x, int y)

{

    int rx, ry;

    rx = findRoot(x);

    ry = findRoot(y);

    if (rx == ry)

        return false;

    num++;

    ufs[rx] = ry;

    return true;

}



bool input()

{

    ans = true;

    num = 0;

    s.clear();

    memset(ufs, 0, sizeof(ufs));

    int u, v;

    for (;;)

    {

        scanf("%d%d", &u, &v);

        if (u == -1 && v == -1)

            return false;

        if (u == 0 && v == 0)

            break;

        s.insert(u);

        s.insert(v);

        if (ans && !mergeUfs(u, v))

            ans = false;

    }

    return true;

}



void output()

{

    if (s.size() && (!ans || s.size()-num != 1))

        printf("No\n");

    else

        printf("Yes\n");

}



int main()

{

    //freopen("test.in", "r", stdin);

    while (input())

    {

        output();

    }

    return 0;

}

 

你可能感兴趣的:(ACM)