hdu 4300 Clairewd’s message(KMP)

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2512    Accepted Submission(s): 983

Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

 

Output
For each test case, output one line contains the shorest possible complete text.
 

 

Sample Input
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

 

Sample Output
abcdabcd qwertabcde
 
//在字符串中找到匹配的位置,就可以了

#include<iostream>

#include<cstdio>

#include<cstring>

using namespace std;

#define N 100010

int p[N],a[30];

char s[N],ss[30];

void getNext(){

	int i=0,j=-1;

	p[0]=-1;

	while(s[i]){

		if(j==-1||s[i]==s[j]){//j为前缀

			i++,j++;

			if(s[i]==s[j])p[i]=p[j];

			else p[i]=j;

		}else j=p[j];

	}

}

int kmp(int i){

	//cout<<"pos:"<<i<<endl;

	int j=0,pos=i;

	while(s[i]){

		if(j==-1||a[s[j]-'a']==s[i]-'a'){i++;j++;}

		else{

			j=p[j];

			pos=i-j;

		}

	}

	return pos;//匹配的位置

}

int main(){

	int T,pos,i;

	scanf("%d",&T);

	while(T--){

		scanf("%s%s",ss,s);

		for(i=0;ss[i];i++)a[ss[i]-'a']=i;

		getNext();

		pos=kmp((strlen(s)+1)/2);

		//cout<<pos<<endl;

		for(i=0;i<pos;i++)printf("%c",s[i]);

		for(i=0;i<pos;i++)printf("%c",'a'+a[s[i]-'a']);printf("\n");

	}

return 0;

}

 

你可能感兴趣的:(message)