poj 1922 Ride to School

Ride to School
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19512 Accepted: 7878

Description

Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike. 

We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one. 

We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan. 

Input

There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format: 

Vi [TAB] Ti 

Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti. 

Output

Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

Sample Input

4
20	0
25	-155
27	190
30	240
2
21	0
22	34
0

Sample Output

780
771

Source

Beijing 2004 Preliminary@POJ

写了init,但是忘记调用了。。。
可能一开始精度也有问题,是要尽量要用double float么?
discuss里面,有人说先乘后除精度损失少,这是什么原理呢。。


#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAXN 10005

double len = 4.5;
double arrive_time[MAXN];
int num = 0;

void init()
{
	memset(arrive_time, 0, sizeof(arrive_time));
	num = 0;
}

int main()
{
	int n = 0;
	double vi = 0, ti = 0;
	while (true)
	{
		scanf("%d", &n);
		if (n == 0)
			break;
		init();
		for (int i = 0; i < n; ++i)
		{
			scanf("%lf%lf", &vi, &ti);
			if (ti < 0)
				continue;
			double tmp = 3600 * len / vi;
			arrive_time[num++] = ti + tmp;
		}

		double tmp = 100000000;
		for (int i = 0; i < num; ++i)
		{
			if (arrive_time[i] < tmp)
			{
				tmp = arrive_time[i];
			}
		}

		printf("%d\n", (int)(ceil(tmp)));
	}
	return 0;
}



你可能感兴趣的:(poj 1922 Ride to School)