hdu 1054 Strategic Game(最小顶点覆盖)

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1760    Accepted Submission(s): 742

Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:


hdu 1054 Strategic Game(最小顶点覆盖)
the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)

 

Sample Output
  
  
1 2
 

        典型的最小顶点覆盖!最小顶点覆盖 == 最大匹配(双向图)/2;

          此题有个小细节,数据较大,要用邻接表,不然会超时!

连接:http://acm.hdu.edu.cn/showproblem.php?pid=1054

代码:

#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <vector>
using namespace std;

const int N = 1505;

int pre[N];
bool flag[N];
vector<int> map[N];
int n;

int find(int cur)
{
    int i, k;
    for(i = 0; i < map[cur].size(); i++)
    {
        k = map[cur][i];
        if(!flag[k])
        {
            flag[k] = true;
            if(pre[k] == -1 || find(pre[k]))
            {
                pre[k] = cur;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i, j, r, k, num, sum;
    while(scanf("%d", &n) != EOF)
    {
        memset(pre, -1, sizeof(pre));
        for(i = 0; i < n; i++) map[i].clear();
        for(i = 0; i < n; i++)
        {
            scanf("%d:(%d)", &k, &num);
            for(j = 0; j < num; j++)
            {
                scanf("%d", &r);
                map[k].push_back(r);	//用邻接表
                map[r].push_back(k);	//建双向图
            }
        }
        sum = 0;
        for(i = 0; i < n; i++)
        {
            memset(flag, false, sizeof(flag));
            sum += find(i);
        }
        printf("%d\n", sum/2);
    }

    return 0;
}

 

 

 

你可能感兴趣的:(数据结构,算法,ACM,二分图)