九度教程81题-确定比赛的名次

题目描述:

有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

输入:

输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

输出:

给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

样例输入:
4 3
1 2
2 3
4 3
样例输出:
1 2 4 3


#include<stdio.h>
#include<vector>
#include<queue>
using namespace std;
vector<int> edge[501];
int degree[501];
priority_queue<int,vector<int>,greater<int> > Q;

int main(){
    int n,m;
    while (scanf("%d%d",&n,&m) != EOF){
          for (int i = 1;i <= n;i++) {
              degree[i] = 0;
              edge[i].clear();    
          } 
          while (m--){
                int a,b;
                scanf("%d%d",&a,&b);
                edge[a].push_back(b);
                degree[b] ++;      
          }
          while (Q.empty() == false){
                Q.pop();      
          }
          for (int i = 1;i <= n;i++){
              if( degree[i] == 0)
                  Q.push(i);    
          } 
          int cnt = 0;
          while (Q.empty() == false){
                int t = Q.top();
                Q.pop();
                cnt++;
                printf("%d",t);
                if(cnt != n){
                    printf(" ");       
                }else {
                    printf("\n");      
                }
                for( int j = 0;j < edge[t].size();j++){
                     degree[edge[t][j]] -- ;
                     if(degree[edge[t][j]] == 0){
                         Q.push(edge[t][j]);                      
                     }     
                }      
          }
    }

    return 0;
}




你可能感兴趣的:(九度教程81题-确定比赛的名次)