HDU2035

人见人爱A^B
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7596    Accepted Submission(s): 5452


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”


Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。


Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。


Sample Input

2 3
12 6
6789 10000
0 0



Sample Output

8
984
1

这个题目注意两点:

(1)取a的后三位计算即可: a%1000

(2)会使用取模定理:  (a*b)%1000 == ((a%1000) * (b%1000)) % 1000

如果,不考虑(2)的话,会溢出(long long都会溢出).
#include <stdio.h>

int main()
{
	int a, b,temp, i;
	while(scanf("%d%d", &a, &b) == 2)
	{
		if(!a && !b)
			break;
		temp = 1;
		for(i = 0; i < b; i++)
		{
			temp = ((a % 1000) * (temp % 1000)) % 1000;
		}
		printf("%d\n", temp);
	}
	return 0;
}

你可能感兴趣的:(HDU)