拓扑:
R1:
interface FastEthernet0/0
ip address 172.16.1.254 255.255.255.0
duplex auto
speed auto
interface Serial2/0
ip address 10.1.1.1 255.255.255.252
serial restart-delay 0
router eigrp 100
network 0.0.0.0
auto-summary
R2:
interface FastEthernet0/0
ip address 172.16.2.254 255.255.255.0
duplex auto
speed auto
interface Serial2/0
ip address 10.1.1.2 255.255.255.252
serial restart-delay 0
clock rate 64000
router eigrp 100
network 0.0.0.0
auto-summary
PC1:
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
ip default-gateway 172.16.1.254
PC2:
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
duplex auto
speed auto
ip default-gateway 172.16.2.254
R1:ip route
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.16.0.0/16 is a summary, 00:06:32, Null0
C 172.16.1.0/24 is directly connected, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial2/0
D 10.0.0.0/8 is a summary, 00:06:46, Null0
R2: ip route
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D 172.16.0.0/16 is a summary, 00:06:56, Null0
C 172.16.2.0/24 is directly connected, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.0/30 is directly connected, Serial2/0
D 10.0.0.0/8 is a summary, 00:06:56, Null0
很明显,现在PC1和PC2不能ping通。
下面来关闭EIGRP的auto-summary
R1(config)#
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R2(config)#router eigrp 100
R2(config-router)#
R2(config-router)#no auto-summary
R1:
interface FastEthernet0/0
ip address 172.16.1.254 255.255.255.0
duplex auto
speed auto
interface Serial2/0
ip address 10.1.1.1 255.255.255.252
serial restart-delay 0
router eigrp 100
network 0.0.0.0
no auto-summary
R2:
interface FastEthernet0/0
ip address 172.16.2.254 255.255.255.0
duplex auto
speed auto
interface Serial2/0
ip address 10.1.1.2 255.255.255.252
serial restart-delay 0
clock rate 64000
router eigrp 100
network 0.0.0.0
no auto-summary
R1: ip route
172.16.0.0/24 is subnetted, 2 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0
D 172.16.2.0 [90/2172416] via 10.1.1.2, 00:01:44, Serial2/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial2/0
R2: ip route
172.16.0.0/24 is subnetted, 2 subnets
D 172.16.1.0 [90/2172416] via 10.1.1.1, 00:02:21, Serial2/0
C 172.16.2.0 is directly connected, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial2/0
经验证,现在PC1,和PC2能正常通信。
总结:
1.EIGRP自动汇总,默认下为打开的
2.EIGRP自动汇总会将主类网络汇总,从而使部分网络不能通信。
3.建议关闭EIGRP自动汇总,通过手工来对其汇总。