CCNP实验二:EIGRP手动汇总

1.   EIGRP配置实验手动汇总

1.1.  文档介绍

本文档主要讲述了 EIGRP 的手动汇总。 EIGRP 默认是使用自动汇总。自动汇总在不连续子网、次有路由选择上存在问题,因此需要我们对 EIGRP 路由进行手动汇总。

1.2.  实验拓扑

1.3.  实验配置

1.3.1.   R1

 
R1#sh run
Building configuration...
 
Current configuration : 1276 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
ip cef
multilink bundle-name authenticated
!
// 启用三个 loopback
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 1.1.2.1 255.255.255.0
!
interface Loopback2
 ip address 1.1.3.1 255.255.255.0
!
interface FastEthernet0/0   // R2f0/0
 ip address 12.1.1.1 255.255.255.0
 ip summary-address eigrp 1 1.1.0.0 255.255.0.0 5
// 在路由出口汇总三个 loopback 口的子网为 16
 duplex auto
 speed auto
!
router eigrp 1
 network 1.0.0.0
 network 12.0.0.0 0.0.0.255
 network 12.0.0.0
 no auto-summary // 取消自动汇总
!
no ip http server
no ip http secure-server
!        
!
!
logging alarm informational
!
!
control-plane
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
end
 
 
 

1.3.2.   R2配置

 
R2#sh run
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
no ip domain lookup
!
interface FastEthernet0/0
 ip address 12.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
!
interface FastEthernet2/0
 ip address 23.1.1.2 255.255.255.0
 duplex half
!
!
//EIGRP 配置
router eigrp 1
 network 12.0.0.0
 network 23.0.0.0
 auto-summary
!
!
!
logging alarm informational
!
gatekeeper
 shutdown
!
!
line con 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
end
 
 

1.3.3.   R3配置

R3#sh run
Building configuration...
 
Current configuration : 1128 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
no ip domain lookup
!
interface Loopback0
 ip address 3.1.1.1 255.255.255.0
!        
interface Loopback1
 ip address 3.1.2.1 255.255.255.0
!
interface Loopback2
 ip address 3.1.3.1 255.255.255.0
!
!
interface FastEthernet2/0
 ip address 23.1.1.3 255.255.255.0
 duplex half
!
!
router eigrp 1
 network 3.0.0.0
 network 23.0.0.0
 auto-summary
!
!
gatekeeper
 shutdown
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
!
!
End
 
 

1.4.  查看路由表

1.4.1.1.            R1路由表

默认自动汇总
R1#sh ip route
     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       1.1.1.0/24 is directly connected, Loopback0
D       1.0.0.0/8 is a summary, 00:00:31, Null0 // 汇总路由指向 null0
C       1.1.2.0/24 is directly connected, Loopback1
C       1.1.3.0/24 is directly connected, Loopback2
D    3.0.0.0/8 [90/158720] via 12.1.1.2, 00:36:36, FastEthernet0/0
D    23.0.0.0/8 [90/30720] via 12.1.1.2, 00:36:36, FastEthernet0/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.1.1.0/24 is directly connected, FastEthernet0/0
D       12.0.0.0/8 is a summary, 00:00:31, Null0// 汇总路由指向 null0
 
 
 
当仅仅自动汇总,路由表将显示明细路由,不像自动汇总和手动汇总会指向 NULL0
 
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external ty
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS
       ia - IS-IS inter area, * - candidate default, U - per-user
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/24 is subnetted, 3 subnets
C       1.1.1.0 is directly connected, Loopback0
C       1.1.2.0 is directly connected, Loopback1
C       1.1.3.0 is directly connected, Loopback2
D    3.0.0.0/8 [90/158720] via 12.1.1.2, 02:17:49, FastEthernet0/
D    23.0.0.0/8 [90/30720] via 12.1.1.2, 02:17:49, FastEthernet0/
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/0
 
关闭自动汇总且手动汇总
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D       1.1.0.0/16 is a summary, 00:46:49, Null0 // 指向 NULL0
C       1.1.1.0/24 is directly connected, Loopback0
C       1.1.2.0/24 is directly connected, Loopback1
C       1.1.3.0/24 is directly connected, Loopback2
D    3.0.0.0/8 [90/158720] via 12.1.1.2, 00:32:42, FastEthernet0/0
D    23.0.0.0/8 [90/30720] via 12.1.1.2, 00:32:42, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/0
 
如果没有关闭自动汇总直接进行手动汇总,我们可以发现两种汇总路由都存在于路由表
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
D       1.1.0.0/16 is a summary, 00:00:04, Null0// 指向 NULL0
C       1.1.1.0/24 is directly connected, Loopback0
D       1.0.0.0/8 is a summary, 00:03:19, Null0// 指向 NULL0
C       1.1.2.0/24 is directly connected, Loopback1
C       1.1.3.0/24 is directly connected, Loopback2
D    3.0.0.0/8 [90/158720] via 12.1.1.2, 00:39:23, FastEthernet0/0
D    23.0.0.0/8 [90/30720] via 12.1.1.2, 00:39:23, FastEthernet0/0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.1.1.0/24 is directly connected, FastEthernet0/0
D       12.0.0.0/8 is a summary, 00:03:19, Null0 // 指向 NULL0
 

1.4.1.2.            R2路由表

EIGRP 中无论自动汇总还是手动汇总,汇总路由都会指向 Null0 ,当路由时,找不到符合条件的明细路由,那么该数据包会丢向 null0 (垃圾桶),这样避免了默认路由等潜在的环路可能
 
 
R1自动汇总
 
R2#sh ip route
 
     1.0.0.0/8 is subnetted, 1 subnets
D       1.0.0.0 [90/156160] via 12.1.1.1, 00:05:17, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 23.1.1.3, 01:02:07, FastEthernet2/0
     23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       23.1.1.0/24 is directly connected, FastEthernet2/0
D       23.0.0.0/8 is a summary, 01:03:45, Null0// 指向 NULL0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.1.1.0/24 is directly connected, FastEthernet0/0
D       12.0.0.0/8 is a summary, 01:03:45, Null0// 指向 NULL0
 
 
R1关闭自动汇总且手动汇总
R2#sh ip route
 
     1.0.0.0/16 is subnetted, 1 subnets
D       1.1.0.0 [90/156160] via 12.1.1.1, 00:00:05, FastEthernet0/0 // 汇总成 16
D    3.0.0.0/8 [90/156160] via 23.1.1.3, 00:00:45, FastEthernet2/0
     23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       23.1.1.0/24 is directly connected, FastEthernet2/0
D       23.0.0.0/8 is a summary, 00:00:45, Null0// 指向 NULL0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.1.1.0/24 is directly connected, FastEthernet0/0
D       12.0.0.0/8 is a summary, 00:00:45, Null0// 指向 NULL0
 
不关闭自动汇总情况下手动汇总
 
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       1.1.0.0/16 [90/156160] via 12.1.1.1, 00:05:14, FastEthernet0/0
D       1.0.0.0/8 [90/156160] via 12.1.1.1, 00:00:09, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 23.1.1.3, 00:05:55, FastEthernet2/0
     23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       23.1.1.0/24 is directly connected, FastEthernet2/0
D       23.0.0.0/8 is a summary, 00:05:55, Null0// 指向 NULL0
     12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       12.1.1.0/24 is directly connected, FastEthernet0/0
D       12.0.0.0/8 is a summary, 00:05:55, Null0// 指向 NULL0

你可能感兴趣的:(职场,休闲,ccnp,EIGRP)