基础帧中继实验配置

动态配置
 
frame-relay(config)#frame-relay switching
frame-relay(config)#int s0/0
frame-relay(config-if)#encapsulation frame-relay
frame-relay(config-if)#frame-relay intf-type dce
frame-relay(config-if)#frame-relay lmi-type cisco
frame-relay(config-if)#frame-relay route 102 interface serial 0/1 201
frame-relay(config-if)#frame-relay route 103 interface serial 0/2 301
frame-relay(config-if)#no sh
frame-relay(config-if)#int s0/1
frame-relay(config-if)#encapsulation frame-relay
frame-relay(config-if)#frame-relay intf-type dce
frame-relay(config-if)#frame-relay lmi-type cisco
frame-relay(config-if)#frame-relay route 201 interface serial 0/0 102
frame-relay(config-if)#no sh
frame-relay(config-if)#int s0/2
frame-relay(config-if)#encapsulation frame-relay
frame-relay(config-if)#frame-relay intf-type dce
frame-relay(config-if)#frame-relay lmi-type cisco
frame-relay(config-if)#frame-relay route 301 interface serial 0/0 103
frame-relay(config-if)#no sh
frame-relay(config-if)#end
frame-relay#show frame-relay route
Input Intf       Input Dlci       Output Intf      Output Dlci      Status
Serial0/0        102              Serial0/1        201              inactive
Serial0/0        103              Serial0/2        301              inactive
Serial0/1        201              Serial0/0        102              inactive
Serial0/2        301              Serial0/0        103              inactive
 
r1(config)#int s0/0
r1(config-if)#ip add 123.123.123.1 255.255.255.0
r1(config-if)#frame-relay intf-type dte
r1(config-if)#encapsulation frame-relay
r1(config-if)#frame-relay lmi-type cisco
r1(config-if)#no sh
r1(config-if)#end
r1#show frame-relay map
Serial0/0 (up): ip 123.123.123.2 dlci 102(0x66,0x1860), dynamic,
              broadcast,, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 103(0x67,0x1870), dynamic,
              broadcast,, status defined, active
 
r2(config)#int s0/1
r2(config-if)#encapsulation frame-relay
r2(config-if)#frame-relay lmi-type cisco
r2(config-if)#frame-relay intf-type dte
r2(config-if)#ip add 123.123.123.2 255.255.255.0
r2(config-if)#no sh
r2(config-if)#end
r2#show frame-relay map
Serial0/1 (up): ip 123.123.123.1 dlci 201(0xC9,0x3090), dynamic,
              broadcast,, status defined, active
r2#ping 123.123.123.1  
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
 
r3(config)#int s0/2
r3(config-if)#encapsulation frame-relay
r3(config-if)#frame-relay intf-type dte
r3(config-if)#frame-relay lmi-type cisco
r3(config-if)#ip add 123.123.123.3 255.255.255.0
r3(config-if)#no sh
r3(config-if)#end
r3#show frame-relay map
Serial0/2 (up): ip 123.123.123.1 dlci 301(0x12D,0x48D0), dynamic,
              broadcast,, status defined, active
r3#ping 123.123.123.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
 
 
手动配置
 
r1(config)#int s0/0
r1(config-if)#no frame-relay inverse-arp
r1(config-if)#frame-relay map ip 123.123.123.2 102
r1(config-if)#frame-relay map ip 123.123.123.3 103
r1(config-if)#no sh
r1(config-if)#exit
r1#show frame-relay map
Serial0/0 (up): ip 123.123.123.2 dlci 102(0x66,0x1860), static,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 103(0x67,0x1870), static,
              CISCO, status defined, active
r1#ping 123.123.123.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 76/144/208 ms
r1#ping 123.123.123.3
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/136/224 ms
 
 
r2(config)#int s0/1
r2(config-if)#sh
r2(config-if)#no frame-relay inverse-arp
r2(config-if)#frame-relay map ip 123.123.123.1 201
r2(config-if)#frame-relay map ip 123.123.123.3 201
r2(config-if)#no sh
r2(config-if)#end
r2#show frame-relay map
Serial0/1 (up): ip 123.123.123.1 dlci 201(0xC9,0x3090), static,
              CISCO, status defined, active
Serial0/1 (up): ip 123.123.123.3 dlci 201(0xC9,0x3090), static,
              CISCO, status defined, active
r2#ping 123.123.123.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 132/204/336 ms
r2#ping 123.123.123.3
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 160/264/392 ms
 
r3(config)#int s0/2
r3(config-if)#sh
r3(config-if)#no frame-relay inverse-arp
r3(config-if)#frame-relay map ip 123.123.123.1 301
r3(config-if)#frame-relay map ip 123.123.123.2 301
r3(config-if)#end
r3#show frame-relay map
Serial0/2 (up): ip 123.123.123.1 dlci 301(0x12D,0x48D0), static,
              CISCO, status defined, active
Serial0/2 (up): ip 123.123.123.2 dlci 301(0x12D,0x48D0), static,
              CISCO, status defined, active
r3#ping 123.123.123.1
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/140/280 ms
r3#ping 123.123.123.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/244/424 ms
 
 
帧中继上 RIP
 
Setp 1   // R1.R2.R3 上面启动 RIP 协议 ( 版本 1RIP 为组播 )
r1(config)#int lo 0
r1(config-if)#ip add 1.1.1.1 255.255.255.0
r1(config-if)#no sh
r1(config-if)#router rip
r1(config-router)#net 123.0.0.0
r1(config-router)#net 1.0.0.0
r1(config-router)#end             
r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/24 is subnetted, 1 subnets
C        1.1.1.0 is directly connected, Loopback0
     123.0.0.0/24 is subnetted, 1 subnets
C        123.123.123.0 is directly connected, Serial0/0
 
r2(config)#int lo 0
r2(config-if)#ip add 2.2.2.2 255.255.255.0
r2(config-if)#no sh
r2(config-if)#router rip
r2(config-router)#net 123.0.0.0
r2(config-router)#net 2.0.0.0
r2(config-router)#end
r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     2.0.0.0/24 is subnetted, 1 subnets
C        2.2.2.0 is directly connected, Loopback0
     123.0.0.0/24 is subnetted, 1 subnets
C        123.123.123.0 is directly connected, Serial0/1
 
r3(config)#int lo 0
r3(config-if)#ip add 3.3.3.3 255.255.255.0
r3(config-if)#no sh
r3(config-if)#router rip
r3(config-router)#net 123.0.0.0
r3(config-router)#net 3.0.0.0
r3(config-router)#end
r3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     3.0.0.0/24 is subnetted, 1 subnets
C        3.3.3.0 is directly connected, Loopback0
     123.0.0.0/24 is subnetted, 1 subnets
C        123.123.123.0 is directly connected, Serial0/2
 
Setp 2   //RIP 进程手动指邻居
r1(config)#router rip
r1(config-router)#nei 123.123.123.2
r1(config-router)#nei 123.123.123.3
r1(config-router)#exit
r1(config)#exit
 
r2(config)#router rip
r2(config-router)#neighbor 123.123.123.1
r2(config-router)#exit
r2(config)#exit
 
r3(config)#router rip
r3(config-router)#neighbor 123.123.123.1
r3(config-router)#exit
r3(config)#exit
 
Setp 3    // 查看 RIP 学到的路由
r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/24 is subnetted, 1 subnets
C        1.1.1.0 is directly connected, Loopback0
R     2.0.0.0/8 [120/1] via 123.123.123.2, 00:00:18, Serial0/0
R     3.0.0.0/8 [120/1] via 123.123.123.3, 00:00:16, Serial0/0
     123.0.0.0/24 is subnetted, 1 subnets
C        123.123.123.0 is directly connected, Serial0/0
 
r2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
R     1.0.0.0/8 [120/1] via 123.123.123.1, 00:00:10, Serial0/1
     2.0.0.0/24 is subnetted, 1 subnets
C        2.2.2.0 is directly connected, Loopback0
R     3.0.0.0/8 [120/2] via 123.123.123.1, 00:00:10, Serial0/1
     123.0.0.0/24 is subnetted, 1 subnets
C        123.123.123.0 is directly connected, Serial0/1
 
r3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
R     1.0.0.0/8 [120/1] via 123.123.123.1, 00:00:14, Serial0/2
R     2.0.0.0/8 [120/2] via 123.123.123.1, 00:00:14, Serial0/2
     3.0.0.0/24 is subnetted, 1 subnets
C        3.3.3.0 is directly connected, Loopback0
     123.0.0.0/24 is subnetted, 1 subnets
C        123.123.123.0 is directly connected, Serial0/2
 
 
点对点子接口
 
Setp 1   //R1 建子接口 ( 对应一个网段和一个 DLCI
r1(config)#default int s0/0
r1(config)#int s0/0
r1(config-if)#encapsulation frame-relay
r1(config-if)#exit
r1(config)#interface Serial0/0.2 point-to-point
r1(config-subif)#ip add 12.12.12.1 255.255.255.0
r1(config-subif)#frame-relay interface-dlci 102
r1(config-fr-dlci)#no sh
r1(config-subif)#exit      
r1(config)#int s0/0.3 point-to-point  
r1(config-subif)#ip add 13.13.13.1 255.255.255.0
r1(config-subif)#frame-relay interface-dlci 103
r1(config-fr-dlci)#no sh
r1(config-subif)#exit
 
r2(config)#int s0/1
r2(config-if)#no   frame-relay map ip 123.123.123.1 201
r2(config-if)#no   frame-relay map ip 123.123.123.3 201
r2(config-if)#frame-relay map ip 12.12.12.1 201
r2(config-if)#no sh
 
r3(config)#int s0/2
r3(config-if)#ip add 13.13.13.3 255.255.255.0
r3(config-if)#no frame-relay map ip 123.123.123.1 301
r3(config-if)#no   frame-relay map ip 123.123.123.2 301
r3(config-if)#frame-relay map ip 13.13.13.1 301
r3(config-if)#no sh
 
Setp 2 宣千网络
r1(config)#router rip
r1(config-router)#ver 2
r1(config-router)#net 12.0.0.0
r1(config-router)#net 13.0.0.0
r1(config-router)#exit
 
r2(config)#router rip
r2(config-router)#ver 2
r2(config-router)#net 12.0.0.0
r2(config-router)#exit
 
r3(config)#router rip
r3(config-router)#ver 2
r3(config-router)#net 13.0.0.0
r3(config-router)#end
 
Setp 3 查看 R1.R2.R3 的路由表
r1#clear ip route *
r2#clear ip route *
r3#clear ip route *
 
r1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/24 is subnetted, 1 subnets
C        1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
R        2.2.2.0 [120/1] via 12.12.12.2, 00:00:50, Serial0/0.2
     3.0.0.0/24 is subnetted, 1 subnets
R        3.3.3.0 [120/1] via 13.13.13.3, 00:00:50, Serial0/0.3
     12.0.0.0/24 is subnetted, 1 subnets
C        12.12.12.0 is directly connected, Serial0/0.2
     13.0.0.0/24 is subnetted, 1 subnets
C        13.13.13.0 is directly connected, Serial0/0.3
 
r2#show ip route   
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/24 is subnetted, 1 subnets
R        1.1.1.0 [120/1] via 12.12.12.1, 00:00:03, Serial0/1
     2.0.0.0/24 is subnetted, 1 subnets
C        2.2.2.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
R        3.3.3.0 [120/2] via 12.12.12.1, 00:00:03, Serial0/1
     12.0.0.0/24 is subnetted, 1 subnets
C        12.12.12.0 is directly connected, Serial0/1
     13.0.0.0/24 is subnetted, 1 subnets
R        13.13.13.0 [120/1] via 12.12.12.1, 00:00:03, Serial0/1
 
r3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     1.0.0.0/24 is subnetted, 1 subnets
R        1.1.1.0 [120/1] via 13.13.13.1, 00:00:00, Serial0/2
     2.0.0.0/24 is subnetted, 1 subnets
R        2.2.2.0 [120/2] via 13.13.13.1, 00:00:00, Serial0/2
     3.0.0.0/24 is subnetted, 1 subnets
C        3.3.3.0 is directly connected, Loopback0
     12.0.0.0/24 is subnetted, 1 subnets
R        12.12.12.0 [120/1] via 13.13.13.1, 00:00:00, Serial0/2
     13.0.0.0/24 is subnetted, 1 subnets
C        13.13.13.0 is directly connected, Serial0/2

你可能感兴趣的:(职场,休闲,lab,帧中继)