帧中继中配EIGRP(hub-spoke)
R1:
interface Loopback0
ip address 1.1.1 .1 255.255.255.0
interface Serial1/1
ip address 123.1.1.1 255.255.255.0
encapsulation frame-relay
no ip split-horizon eigrp 1
serial restart-delay 0
frame-relay map ip 123.1.1.3 103 broadcast
frame-relay map ip 123.1.1.1 102 broadcast
frame-relay map ip 123.1.1.2 102 broadcast
no frame-relay inverse-arp
router eigrp 1
network 1.1.1 .0 0.0.0.255
network 123.1.1.0 0.0.0 .255
no auto-summary
==================================================
R2:
interface Loopback0
ip address 2.2.2 .2 255.255.255.0
interface Serial1/1
ip address 123.1.1.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 123.1.1.3 201 broadcast
frame-relay map ip 123.1.1.1 201 broadcast
frame-relay map ip 123.1.1.2 201 broadcast
no frame-relay inverse-arp
router eigrp 1
network 2.2.2 .0 0.0.0.255
network 123.1.1.0 0.0.0 .255
no auto-summary
===============================================
R3:
interface Loopback0
ip address 3.3.3 .3 255.255.255.0
interface Serial1/1
ip address 123.1.1.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 123.1.1.3 301 broadcast
frame-relay map ip 123.1.1.1 301 broadcast
frame-relay map ip 123.1.1.2 301 broadcast
no frame-relay inverse-arp
router eigrp 1
network 3.3.3 .0 0.0.0.255
network 123.1.1.0 0.0.0 .255
no auto-summary
================================================
EIGRP的水平分割默认是打开的,这样只有R1、R2和R1、R3之间能学到路由,而R2、R3没法学到对方的路由信息。
关闭水平分割:
R1(config-if)#no ip split-horizon ei 1
这样,R2、R3就可以学到对方的路由信息了。