HDU 1082.Matrix Chain Multiplication【栈的应用+矩阵乘法规则】【1月4】

Matrix Chain Multiplication

Problem Description
Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.
 

Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"
 

Output
For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.
 

Sample Input
   
   
   
   
9 A 50 10 B 10 20 C 20 5 D 30 35 E 35 15 F 15 5 G 5 10 H 10 20 I 20 25 A B C (AA) (AB) (AC) (A(BC)) ((AB)C) (((((DE)F)G)H)I) (D(E(F(G(HI))))) ((D(EF))((GH)I))
 

Sample Output
   
   
   
   
0 0 0 error 10000 error 3500 15000 40500 47500 15125

题意就是给你n个xi行yi列的矩阵,然后再给给你好多个矩阵相乘的式子,让你计算在这个矩阵乘法的计算中用到了多少次初等乘法。矩阵相乘,只有第一个矩阵的列跟第二个矩阵的行相等是才能计算。如遇到不能计算的就输出error。

因为计算式子有括号,可以用栈来操作优先级,而矩阵则可用map来保存。

代码:

#include<iostream>
#include<cstdio>
#include<map>
#include<stack>
#include<cstring>
using namespace std;
typedef long long int LL;
typedef pair <LL, LL> P;
LL len, row, column, ans;
char ch, s[100100];
map <int, P> f;
bool flag;
int n;
int main()
{
    cin >> n;
    for(int i = 0;i < n; i++)
    {
        cin >> ch >> row >> column;
        f[ch-'A']  = make_pair(row, column);//键值转化成int型的好用
        //cout << ch-'A' <<" "<< f[ch-'A'].first <<" "<< f[ch-'A'].second <<endl;
    }
    while(cin >> s)
    {
        ans = 0;
        stack <int> z;
        int x = 30;
        flag = true;
        len = strlen(s);
        for(int i = 0;i < len; ++i)
        {
            if(s[i] == '(') continue;
            if(s[i] == ')')//遇到一个右括号,弹出两个矩阵进行计算
            {
                int b = z.top();
                z.pop();
                int a = z.top();
                z.pop();
                if(f[a].second != f[b].first)//无法计算,error
                {
                    flag = false;
                    break;
                }
                else ans +=(f[a].first*f[b].second*f[a].second);//计数
                z.push(x);//把运算得出的矩阵放入栈中
                f[x++] = make_pair(f[a].first, f[b].second);//把运算得到的矩阵放入map中保存,下次计算调用
            }
            else z.push(s[i]-'A');//遇到矩阵直接放入
        }
        if(!flag) cout <<"error\n";
        else cout << ans << endl;
    }

    return 0;
}


你可能感兴趣的:(C++,栈,ACM,矩阵,HDU)