UVa 10305 - Ordering Tasks【拓扑排序】

Ordering Tasks

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 n 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will nish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3
#include<cstdio>
#include<algorithm>
#include<cstring>
const int maxn=110;
int c[maxn],topo[maxn],t,n,G[maxn][maxn];
bool dfs(int u){
    c[u]=-1;
    for(int v=1;v<=n;v++)
        if(G[u][v]){
            if(c[v]<0) return false;
            else if(!c[v]&&!dfs(v)) return false;
        }
    c[u]=1;
    topo[--t]=u;
    return true;
}
bool toposort(){
    t=n;
    memset(c,0,sizeof(c));
    for(int i=1;i<=n;i++)
        if(!c[i]&&!dfs(i))  return false;
    return true;
}
int main()
{
    int m;
    while(scanf("%d%d",&n,&m),n||m){
        int u,v;
        memset(G,0,sizeof(G));
        for(int i=0;i<m;i++){
            scanf("%d%d",&u,&v);
            G[u][v]=1;
        }
        if(toposort())
            for(int i=0;i<n;i++){
                if(i!=0) printf(" ");
                printf("%d",topo[i]);
            }
        printf("\n");
    }
    return 0;
}


你可能感兴趣的:(sizeof,ACM,uva)