hdoj 2602 Bone Collector【0-1背包】【dp思想】

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40247    Accepted Submission(s): 16722


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
hdoj 2602 Bone Collector【0-1背包】【dp思想】_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 

题意:给一定数量的骨头的价格和体积,装进背包,求所能装下的骨头的最大价值
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int value,vol;
}; 
node p[1010];
int bag[1100];
int main()
{
	int i,j,k,t,n,v;
	scanf("%d",&t);//总情况数 
	while(t--)
	{
		memset(bag, 0, sizeof(bag));//全初始化为 0 
		scanf("%d%d",&n,&v);//n数量,v体积 
		for(i = 1; i <= n; i++)
			scanf("%d",&p[i].value);//输入每个骨头的价值 
		for(i = 1; i <= n; i++)
			scanf("%d",&p[i].vol);//输入每个骨头所占体积 
		for(i = 1; i <= n ;i++)//数量变化 
		{
			for( j = v; j >= p[i].vol;j--)// 体积控制,背包如果可以装下骨头就继续 
			{	//动态规划过程 
				bag[j] = max(bag[j], bag[j-p[i].vol]+p[i].value);//当前与下一个取价值最大的 
			}
		}
		printf("%d\n",bag[v]);//输出装的最多价值 
	}
	return 0;
}






你可能感兴趣的:(hdoj 2602 Bone Collector【0-1背包】【dp思想】)