Bone Collector
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39612 Accepted Submission(s): 16412
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 2
31).
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output
Author
Teddy
Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
Recommend
lcy | We have carefully selected several similar problems for you: 1203 2159 2955 1171 2191
Statistic | Submit | Discuss | Note
非常常规的0 1背包问题。
第一排输入的是价值,第二排是体积
#include <stdio.h>
#include <string.h>
int main()
{
int n,v;
int ncase,dp[1005],val[1005],vol[1005];
scanf("%d",&ncase);
while(ncase--)
{
memset(dp,0,sizeof(dp));
memset(val,0,sizeof(val));
memset(vol,0,sizeof(vol));
scanf("%d %d",&n,&v);
for(int i=0;i<n;i++)
scanf("%d",&val[i]);
for(int i=0;i<n;i++)
scanf("%d",&vol[i]);
int max=0;
for(int i=0;i<n;i++)
{
for(int j=v;j>=vol[i];j--)
{
if(dp[j]<dp[j-vol[i]]+val[i])
dp[j]=dp[j-vol[i]]+val[i];
if(dp[j]>max)
max=dp[j];
}
}
printf("%d\n",max);
}
}