hdu2031 进制转换

进制转换

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32078    Accepted Submission(s): 17805


Problem Description
输入一个十进制数N,将它转换成R进制数输出。
 

Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
 

Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
 

Sample Input
   
   
   
   
7 2 23 12 -4 3
 

Sample Output
   
   
   
   
111 1B -11
 

Author
lcy
 

Source
C语言程序设计练习(五)
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2035  2029  2034  2028  2021 
 

Statistic |  Submit |  Discuss |  Note

如果不是事例中有个负数,我想我是想不到了。。大哭

#include <stdio.h>
#include <stack>
using namespace std;
int main()
{
	stack<int>s;
	int m,r;
	while(~scanf("%d %d",&m,&r))
	{
		int flag=0;
		if(m<0)
		m=-m,flag=1;
		while(m)
		s.push(m%r),m=m/r;
		if(flag)
		printf("-");
		while(!s.empty())
		{
			if(s.top()>=10)
			printf("%c",'A'-10+s.top());
			else
			printf("%d",s.top());
			s.pop();
		}
		printf("\n");
	}
	return 0;
}



你可能感兴趣的:(进制转换,HDU,2031,hdu2031)