HDU 5512 Pagodas 找规律 (2015ACM/ICPC亚洲区沈阳站)

【题目链接】:click here~~

【题目大意】:

Pagodas

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 15    Accepted Submission(s): 14


Problem Description
n  pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from  1  to  n . However, only two of them (labelled  a and  b , where  1abn ) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled  i (i{a,b} and 1in)  if there exist two pagodas standing erect, labelled  j  and  k  respectively, such that  i=j+k  or  i=jk . Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
 

Input
The first line contains an integer  t (1t500)  which is the number of test cases.
For each test case, the first line provides the positive integer  n (2n20000)  and two different integers  a  and  b .
 

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
 

Sample Input
   
   
   
   
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
 

Sample Output
   
   
   
   
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
大致题意:1~n座宝塔,a,b两座完好,现要重建其他宝塔,且满足条件宝塔编号i属于【1,n】且不属于【a,b】且i等于已经存在的宝塔的j和k之和或之差。最后谁不能重建则为败者,

【思路】(n/gcd(a,b)&1)即可

代码:

/*  
* Problem: HDU No.5512
* Running time: 0MS  
* Complier: G++  
* Author: javaherongwei 
* Create Time: 17:30 2015/10/31 星期六
*/  
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;

int main()
{
     int t,tot=1;
     scanf("%d",&t);
     while(t--)
     {
         int n,a,b;
         scanf("%d%d%d",&n,&a,&b);
         int gcd=__gcd(a,b);
         int ans=n/gcd;
         printf("Case #%d: ",tot++);
         if(ans&1) puts("Yuwgna");
         else  puts("Iaka");
     }
     return 0;
}


你可能感兴趣的:(HDU,ACMICPC)