UVA之11300 - Spreading the Wealth

 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

【题意】

UVA之11300 - Spreading the Wealth_第1张图片

【解析】

UVA之11300 - Spreading the Wealth_第2张图片

UVA之11300 - Spreading the Wealth_第3张图片

【代码】

/*********************************
*   日期:2013-11-22
*   作者:SJF0115
*   题号: 题目11300 - Spreading the Wealth
*   来源:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=25&page=show_problem&problem=2275
*   结果:AC
*   来源:UVA
*   总结:
**********************************/
#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

#define N 1000000 + 10

long long Money[N],C[N],total,M,FirstMoney,ans;

int main() {
    int i,n;
    while(scanf("%d",&n) != EOF){
        total = 0;
        //每人分得的金币
        for(i = 0;i < n;i++){
            scanf("%lld",&Money[i]);
            //总金额
            total+= Money[i];
        }
        //均摊后的金币
        M = total / n;
        C[0] = 0;
        for(i = 1;i < n;i++){
            C[i] = C[i-1] + Money[i-1] - M;
        }
        //排序
        sort(C,C+n);
        //取中位数
        FirstMoney = C[n/2];
        ans = 0;
        //计算转移的金币总额
        for(i = 0;i < n;i++){
            ans += abs(FirstMoney - C[i]);
        }
        printf("%lld\n",ans);
    }//while
    return 0;
}





你可能感兴趣的:(uva,剑指offer)