HDU 2132 An easy problem 小技巧

An easy problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5719    Accepted Submission(s): 1556


Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-
 

Input
  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.
 

Output
  output the result sum(n).
 

Sample Input
   
   
   
   
1 2 3 -1
 

Sample Output
   
   
   
   
1 3 30


直接模拟就可以了 但要注意的是用__int64来进行存储  下面红线的字体要注意

#include<stdio.h>
__int64  a[100010];

int main()
{
       __int64 i;  i用__int64来存储
       a[0]=0;
       a[1]=1;
       for( i=2; i<=100000; i++ )
       {
          if( i%3==0 ) a[i]=a[i-1]+i*i*i;  //如果 i用int的话 这里会越界 
          else a[i]=a[i-1]+i;    
       }
       int n;
       while(scanf("%d",&n)&&n>=0)
       {
         printf("%I64d\n",a[n]);                          
                                 
       }

}



你可能感兴趣的:(File,Integer,存储,input,IIS,output)