zoj 2781

Rounders Time Limit: 1 Second      Memory Limit: 32768 KB

Introduction

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...

Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output

For each integer in the input, display the rounded integer on its own line.
Note: Round up on fives.

Sample Input

 

9
15
14
4
5
99
12345678
44444445
1445
446

 

Sample Output

 

20
10
4
5
100
10000000
50000000
2000
500
#include <iostream>
#include <string>
using namespace std;

int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		string str = "";
		cin>>str;
		if(str.length()==1)
		{
			cout<<str<<endl;
		}
		else
		{
			int t = 0;
			for ( int i =str.length()-1 ; i >0; i--)
			{
				if((str.at(i)+t)<'5')
				{
					str[i] = '0';
					t = 0;
				}
				else
				{					
					t = 1;					
					str[i] = '0';
				}
			}
			if (t==1)
			{
				if(str.at(0)<='4')
					str[0] = str[0] +1;
				else
				{
					str[0] = '0';
					str = '1'+str;
				}
			}
			else
			{
				if(str.at(0)>'5')
				{
					str[0] = '0';
					str = '1'+str;
				}
			}

			cout<<str<<endl;
		}
	}
	return 0;
} 

你可能感兴趣的:(String,Integer,input,each,output,2010)