Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b's last digit number.
Sample Input
Sample Output
寻找规律。除了0,1,5,6不改变后面数字,4,9两次一循环,其余的都是4次一循环。
#include<stdio.h>
int main()
{
int a,b,s,i,k;
while(scanf("%d%d",&a,&b)!=EOF)
{
if(a%10==0) printf("0\n");
if(a%10==1) printf("1\n");
if(a%10==2)
{
if(b%4==0) printf("6\n");
if(b%4==1) printf("2\n");
if(b%4==2) printf("4\n");
if(b%4==3) printf("8\n");
}
if(a%10==3)
{
if(b%4==0) printf("1\n");
if(b%4==1) printf("3\n");
if(b%4==2) printf("9\n");
if(b%4==3) printf("7\n");
}
if(a%10==4)
{
if(b%2==0) printf("6\n");
else printf("4\n");
}
if(a%10==5) printf("5\n");
if(a%10==6) printf("6\n");
if(a%10==7)
{
if(b%4==0) printf("1\n");
if(b%4==1) printf("7\n");
if(b%4==2) printf("9\n");
if(b%4==3) printf("3\n");
}
if(a%10==8)
{
if(b%4==0) printf("6\n");
if(b%4==1) printf("8\n");
if(b%4==2) printf("4\n");
if(b%4==3) printf("2\n");
}
if(a%10==9)
{
if(b%2==0) printf("1\n");
else printf("9\n");
}
}
return 0;
}