1510 替换空格 @Jobdu

http://ac.jobdu.com/problem.php?pid=1510

题目1510:替换空格

时间限制:1 秒

内存限制:128 兆

特殊判题:

提交:2160

解决:550

题目描述:

请实现一个函数,将一个字符串中的空格替换成“%20”。例如,当字符串为We Are Happy.则经过替换之后的字符串为We%20Are%20Happy。

输入:

每个输入文件仅包含一组测试样例。
对于每组测试案例,输入一行代表要处理的字符串。

输出:

对应每个测试案例,出经过处理后的字符串。

样例输入:
We Are Happy
样例输出:
We%20Are%20Happy
从后向前替换,另外注意在读写时要用Scanner的hasNextLine 才能读入white space


import java.io.BufferedInputStream;
import java.io.FileInputStream;
import java.io.FileNotFoundException;
import java.util.Scanner;


public class S4 {

	public static void main(String[] args) throws FileNotFoundException {
		BufferedInputStream in = new BufferedInputStream(new FileInputStream("S4.in"));
        System.setIn(in);
		Scanner cin = new Scanner(System.in);
		
		while (cin.hasNextLine()) {
			String s = cin.nextLine();
			System.out.println(replace(s));
		}
	}
	
	public static String replace(String s){
		int len = s.length();
		char[] olds = s.toCharArray();
		int space = 0;
		for(int i=0; i<olds.length; i++){
			if(olds[i] == ' '){
				space++;
			}
		}
		
		int newLen = len + 2*space;
		char[] news = new char[newLen];
		int i = len-1;
		int j = newLen-1;
		
		while(i >= 0){
			if(olds[i] != ' '){
				news[j] = olds[i];
				j--;
			}else{
				news[j--] = '0';
				news[j--] = '2';
				news[j--] = '%';
			}
			
			i--;
		}
		
		return new String(news);
	}

}


你可能感兴趣的:(1510 替换空格 @Jobdu)