POJ 2386 Lake Counting 简单的DFS搜索

 

http://poj.org/problem?id=2386
简单DFS搜索
Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
/* Author : yan
 * Question : POJ 2386 Lake Counting
 * Data && Time : Thursday, December 23 2010 10:26 AM
*/
#include<stdio.h>
#define bool _Bool
#define true 1
#define false 0
#define MAXN 103
char value[MAXN][MAXN];
bool visited[MAXN][MAXN];

int n,m;
int cnt;

void DFS(int a,int b)
{
	if(visited[a][b]==true || value[a][b]=='.') return;
	visited[a][b]=true;
	if(a>1 && b>1) DFS(a-1,b-1);
	if(a<n && b<m) DFS(a+1,b+1);
	if(a>1) DFS(a-1,b);
	if(a<n) DFS(a+1,b);
	if(a>1 && b<m) DFS(a-1,b+1);
	if(a<n && b>1) DFS(a+1,b-1);
	if(b>1) DFS(a,b-1);
	if(b<m) DFS(a,b+1);
}
int main()
{
	//freopen("input","r",stdin);
	int i,j;
	int ans=-1;
	scanf("%d %d",&n,&m);
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=m;j++)
		{
			scanf(" %c",&value[i][j]);
		}
	}
	cnt=0;
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=m;j++)
		{

			if( !visited[i][j] && value[i][j]=='W' )
			{
				DFS(i,j);
				cnt++;
			}
			//if(ans<cnt) ans=cnt;
			//printf("%d/n",cnt);
		}
	}
	printf("%d",cnt);
	return 0;
} 

 

你可能感兴趣的:(POJ 2386 Lake Counting 简单的DFS搜索)