How far away ?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2935 Accepted Submission(s): 1095
Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
Input
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
Sample Input
2
3 2
1 2 10
3 1 15
1 2
2 3
2 2
1 2 100
1 2
2 1
Sample Output
Source
ECJTU 2009 Spring Contest
Recommend
lcy
题目大意:一个村子里有n个房子,这n个房子用n-1条路连接起来,接下了有m次询问,每次询问两个房子a,b之间的距离是多少。
从某点到某点有且只有一条路
思路 : DFS 一直D下去 直到找到我们要到的地方 由于无法保存那么大的map路径 可以用vector
#include<stdio.h>
#include<vector>
#include<string.h>
using namespace std;
struct haha
{
int pos;
int val;
}temp,q;
vector<struct haha>a[44444];
int n,m,flag,e,vis[444444];
void DFS(int s,int ans)
{
//printf("s=%d\n",s);
int size,i;
if(vis[s]) return ;
if(flag) return ;
if(s==e) {printf("%d\n",ans);flag=1;return;}
if(a[s].empty()) return ;
else
{
vis[s]=1;
size=a[s].size();
for(i=0;i<size;i++)
DFS(a[s][i].pos,ans+a[s][i].val);
vis[s]=0;
}
}
int main()
{
int cas;
scanf("%d",&cas);
while(cas--)
{
int i,j,x,y,z;
scanf("%d %d",&n,&m);
for(i=0;i<n-1;i++)
{
scanf("%d %d %d",&x,&y,&z);
q.pos=y;q.val=z;
a[x].push_back(q);
q.pos=x;q.val=z;
a[y].push_back(q);
}
for(j=0;j<m;j++)
{
memset(vis,0,sizeof(vis));
flag=0;
int s;
scanf("%d %d",&s,&e);
DFS(s,0);
}
for(i=0;i<n;i++)
{
a[i].clear();
}
}
return 0;
}