ACM-DFS之Tempter of the Bone——hdu1010

Tempter of the Bone

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
   
   
   
   
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
   
   
   
   
NO YES 深度优先搜索的题目,这道题难点在于减枝, 第一部分的最小步数就不用多说了,剩余时间必须大于最小步数才可以到达。 第二部分奇偶减枝是比较重要的,就是说: 剩余的时间减去最短路径所需要的步数, 所剩余的额外的步数必定是偶数, 因为,额外的步数, 肯定是从最短路径出去,必定还要回来, 出去回来所需要的步数一定为偶数, 这就是奇偶减枝。
#include <iostream>
using namespace std;

char map[101][101];
int n,m,fx,fy;
bool isok;

void dfs(int x,int y,int time)
{
	// 查看是否已经找到答案
    if(isok==1)    return;
    // 是否越界或撞墙。。
	if(x<0 || y<0 || x>n-1 || y>m-1 || time<0 || map[x][y]=='X')    return;
    // 减枝,第一部分是:最短步数减枝;第二部分是奇偶减枝;
	if(time<abs(fx-x)+abs(fy-y)||(time-(abs(fx-x)+abs(fy-y)))%2)    return;
    // 是否到了终点
	else if(time==0 && (fx==x&&fy==y)) {isok=true;return;}
	// 否则,四个方向遍历吧,这次没用数组,看着繁琐了点
    else
    {		
        map[x][y]='X';
        dfs(x-1,y,time-1);
        map[x][y]='.';
        
        map[x][y]='X';
        dfs(x+1,y,time-1);
        map[x][y]='.';
        
        map[x][y]='X';
        dfs(x,y-1,time-1);
        map[x][y]='.';
        
        map[x][y]='X';
        dfs(x,y+1,time-1);
        map[x][y]='.';
    }
    return;
    
}



int main()
{
    int i,j,sx,sy,t;
    
    
    while(cin>>n>>m>>t)
    {
        if(n==0 && m==0 && t==0)    break;
     // 输入
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
            {
                cin>>map[i][j];
                if(map[i][j]=='S')
                {    sx=i;    sy=j;    }
                else if(map[i][j]=='D')
                {    fx=i;    sy=j;    }
            }
            
            isok=false;
            dfs(sx,sy,t);
     // 输出
            if(isok==1)    cout<<"YES"<<endl;
            else    cout<<"NO"<<endl;
    }
    return 0;
}

你可能感兴趣的:(ACM,DFS,of,the,Bone,Tempter,hdu1010)