POJ-3253-优先队列

  Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 25103   Accepted: 8090

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needsN (1 ≤N ≤ 20,000) planks of wood, each having some integer lengthLi (1 ≤Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into theN planks (i.e., whose length is the sum of the lengthsLi). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of theN-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create theN planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).


该道题目的意思大概都知道了吧?处理这个问题就是每次取两个最小的长度给它组合在一起。所以可以用优先队列来解决。注意,当队列剩下最后一个元素的时候就可以停止了。不说了,上代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    long long a[20005];
    long long t1,t2,ans=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%I64d",&a[i]);
    priority_queue<long long,vector<long long>,greater<long long> >que;
    for(int i=0;i<n;i++)
        que.push(a[i]);
    while(que.size()>1)
    {
        t1=que.top();
        que.pop();
        t2=que.top();
        que.pop();
        ans+=(t1+t2);
        que.push(t1+t2);
    }
    printf("%I64d\n",ans);
    return 0;
}


你可能感兴趣的:(poj,优先队列)