PKU 1700 Crossing River

Crossing River
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4231 Accepted: 1392

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

Source

POJ Monthly--2004.07.18

 
分析:
    对n(n>3)个人来说,要将用时最长的两人X、Y过河,有两种方按。
已知:TimeOfA<=TimeOfB<=TimeOfX<=TimeOfY
<1>  将用时最短的两个人A、B先过河,然后A划船返回,然后A下船,X、Y过河,B划船返回。该方案耗时
:TimeOfA+TimeOfB+Max(TimeOfA,TimeOfB)+Max(TimeOfX,TimeOfY)=TimeOfA+2*TimeOfB+TimeOfY.
 <2>  A与Y过河,A划船返回;A与X过河,A划船返回。耗时为:Max(TimeOfA,TimeOfX)+TimeOfA+Max
(TimeOfA,TimeOfY)+TimeOfA=2*TimeOfA+TimeOfX+TimeOfY.
在<1>、<2>方案中选择耗时最小的,然后递归。
#include <iostream>
#include <algorithm>
using namespace std ;

int recursion ( int *num , int n )
{
if (n == 1 ) return num [ 0 ];
else if (n == 2 ) return num [ 1 ];
else if (n == 3 ) return num [ 0 ]+num [ 1 ]+num [ 2 ];
else if ( 2 *num [ 1 ]<num [ 0 ]+num [n -2 ])
return 2 *num [ 1 ]+num [n -1 ]+num [ 0 ]+ recursion (num ,n -2 );
else if ( 2 *num [ 1 ]>=num [ 0 ]+num [n -2 ])
return 2 *num [ 0 ]+num [n -2 ]+num [n -1 ]+ recursion (num ,n -2 );
}

int main ()
{
int T ;
int n ;
cin >>T ;
while (T --)
{
cin >>n ;
int i ,s ;
s = 0 ;
int *time = new int [n ];
for (i = 0 ;i <n ;i ++)
cin >>time [i ];
std :: sort (time ,time +n );

cout << recursion (time ,n )<<endl ;
}
return 0 ;
}

你可能感兴趣的:(PKU 1700 Crossing River)