HDU_ACM step 1.2.1 A+B Coming

版权所有,欢迎转载,转载请注明出处,谢谢微笑

A+B Coming

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4716 Accepted Submission(s): 2130
 
Problem Description
Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^
 
Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.
 
Output
Output A+B in decimal number in one line.
 
Sample Input
1 9
A B
a b
 
Sample Output
10
21
21

基础,这道题主要是练习如何输入16进制的数。
 
#include<iostream>
#include<string>
using namespace std;

int main()
{
	int a ,b ;
	while(cin>>hex>>a>>hex>>b)
	{
		cout<<a+b<<endl;
	}
	return 0;
}



你可能感兴趣的:(Algorithm,算法,快速排序,ACM)