hdu3951 Coin Game---博弈 对称性

Coin Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 747    Accepted Submission(s): 454


Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.
hdu3951 Coin Game---博弈 对称性_第1张图片
The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.

Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=10 9,1<=K<=10).

Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)

Sample Input
   
   
   
   
2 3 1 3 2

Sample Output
   
   
   
   
Case 1: first Case 2: second

Author
NotOnlySuccess

Source
2011 Alibaba Programming Contest

Recommend

lcy

题意:给你一个环,由n个硬币组成,每次只可取连续的1~k个硬币,问你谁有取胜策略。

我们可以利用对称性解题,第一个玩家怎么取,第二个玩家在对称点取一样的,这样先手必败。

#include<iostream>
#include<cstdlib>
#include<stdio.h>
using namespace std;
int main()
{
    int t,n,k;
    int count=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        printf("Case %d: ",count++);
        if(k==1&&(n%2==1)) puts("first");
        else if(n<=k) puts("first");
        else puts("second");
    }
}


你可能感兴趣的:(hdu3951 Coin Game---博弈 对称性)