C++习题 对象数组输入与输出

Problem L: C++习题 对象数组输入与输出

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 477   Solved: 322
[ Submit][ Status][ Web Board]

Description

建立一个对象数组,内放n(n<10)个学生的数据(学号、成绩),用指针指向数组首元素,输出第奇数(1,3,5,7)个学生的数据。

Input

n和n个学生的学号、成绩

Output

奇数学生的数据

Sample Input

5
101 78.5
102 85.5
103 98.5
104 100.0
105 95.5

Sample Output

101 78.50
103 98.50
105 95.50

HINT

主函数已给定如下,提交时不需要包含下述主函数



/* C++代码 */



int main()

{

    const int NUM=10;

    Student stud[NUM];

    int n,i;

    cin>>n;

    for(i=0; i<n; i++)

        stud[i].input();

    cout<<setiosflags(ios::fixed);

    cout<<setprecision(2);

    Student *p=stud;

    for(i=0; i<n; p+=2,i+=2)

        p->display();

    return 0;

}
 
 
#include <iostream>
#include <cstring>
#include <iomanip>
using namespace std;
class Student
{
private:
    string number;
    double scort;
public:
    void input()
    {
        cin>>number>>scort;

    }
    void display()
    {
        cout<<number<<' '<<scort<<endl;
    }
};

你可能感兴趣的:(C++习题 对象数组输入与输出)