PAT 1091. Acute Stroke

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are "connected" and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

PAT 1091. Acute Stroke_第1张图片
Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26

思路:广度搜索,计算连通域的大小,舍去小于阈值的


#include <stdio.h>
#include <string.h>
#include <list>
using namespace std;
int M, N, L, T, step[6][3] = {{0, 0, 1}, {0, 0, -1}, {0, 1, 0}, {0, -1, 0}, {1, 0, 0}, {-1, 0, 0}};
bool map[62][1230][130], visit[62][1230][130];
struct Node
{
	int x, y, z;
	Node(int a, int b, int c)
	{
		x = a;
		y = b;
		z = c;
	}
};

int fun(Node curNode)
{
	int cnt = 0;
	list<Node> stroke;
	stroke.push_back(curNode);
	int length = 0, nextX, nextY, nextZ;
	while(stroke.size())
	{
		length = stroke.size();
		for(int i = 0; i < length; i++)
		{
			curNode = stroke.front();
			for(int j = 0; j < 6; j++)
			{
				nextX = curNode.x + step[j][0];
				nextY = curNode.y + step[j][1];
				nextZ = curNode.z + step[j][2];
				if(nextX >= 0 && nextX < L && nextY >= 0 && nextY < M && nextZ >= 0 && nextZ < N && map[nextX][nextY][nextZ] && !visit[nextX][nextY][nextZ])
				{
					Node newNode = Node(nextX, nextY, nextZ);
					visit[nextX][nextY][nextZ] = true;
					stroke.push_back(newNode);
				}
			}
			cnt++;
			stroke.pop_front();
		}
	}
	return cnt;
}

int main()
{
	memset(map, false, sizeof(map));
	memset(visit, false, sizeof(visit));
	while(scanf("%d %d %d %d", &M, &N, &L, &T) != EOF)
	{
		int temp;
		for(int i = 0; i < L; i++)
		{
			for(int j = 0; j < M; j++)
			{
				for(int k = 0; k < N; k++)
				{
					scanf("%d", &temp);
					map[i][j][k] = (temp == 1);
				}
			}
		}
		int res = 0;
		for(int i = 0; i < L; i++)
		{
			for(int j = 0; j < M; j++)
			{
				for(int k = 0; k < N; k++)
				{
					if(map[i][j][k] && !visit[i][j][k])
					{
						visit[i][j][k] = true;
						temp = fun(Node(i, j, k));
						res += temp >= T ? temp : 0;
					}
				}
			}
		}
		printf("%d\n", res);
	}
	return 0;
}


 

你可能感兴趣的:(PAT 1091. Acute Stroke)