hdu4287 Intelligent IME-----天津网络赛

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 495    Accepted Submission(s): 260


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?


 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.


 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.


 

Sample Input
   
   
   
   
1 3 5 46 64448 74 go in night might gn


 

Sample Output
   
   
   
   
3 2 0


 

Source
2012 ACM/ICPC Asia Regional Tianjin Online


 

Recommend
liuyiding

 

 

 

 

#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
#include<string.h>
#define mm 1000007
using namespace std;
char ss[5010][10];
struct hashtable
{
    int h[mm],next[mm],size,num[mm];
    char sty[mm][10];
   int ELFHash(char *str)
{
    unsigned long h=0;
    while(*str!='\0')
    {
        h=(h<<4)+(*str);str++;
        unsigned long g=h&0xf0000000L;
        if(g!=0)
        h^g>>24;
        h&=~g;
    }
    return h%mm;
}


 void insert(char *s)
 {
     int key=ELFHash(s);
     for(int i=h[key];i>=0;i=next[i])
     if(!strcmp(sty[i],s)){num[i]++;return ;}
     num[size]=1;next[size]=h[key];h[key]=size;strcpy(sty[size],s);size++;

 }
 int find(char *s)
 {
     int key=ELFHash(s);
     for(int i=h[key];i>=0;i=next[i])
     if(!strcmp(sty[i],s)) return num[i];
     return 0;
 }
 void clear()
 {
     memset(h,-1,sizeof(h));
     size=0;
 }
}g;

int main()
{
    int t,n,m;
    char s[550];
    s['a']=s['b']=s['c']='2';
    s['d']=s['e']=s['f']='3';
    s['g']=s['h']=s['i']='4';
    s['j']=s['k']=s['l']='5';
    s['m']=s['n']=s['o']='6';
    s['p']=s['q']=s['r']=s['s']='7';
    s['t']=s['u']=s['v']='8';
    s['w']=s['x']=s['y']=s['z']='9';

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
        scanf("%s",ss[i]);
        char tt[10];
        g.clear();
        for(int i=0;i<m;i++)
        {
            scanf("%s",tt);
            for(int j=0;j<strlen(tt);j++)
            {
              tt[j]=s[tt[j]];
            }
            g.insert(tt);
        }
        for(int i=0;i<n;i++)
        {
            int ans=g.find(ss[i]);
            cout<<ans<<endl;
        }
    }
}

/*
1
3 5
46
64448
74
go
in
night
might
gn
*/


 

你可能感兴趣的:(网络,Integer,input,each,Dictionary,output)