Time Limit: 3500MS | Memory Limit: 65536K | |
Total Submissions: 8864 | Accepted: 3088 |
Description
Input
Output
Sample Input
4 1 0 0 1 1 1 0 0 9 0 0 1 0 2 0 0 2 1 2 2 2 0 1 1 1 2 1 4 -2 5 3 7 0 0 5 2 0
Sample Output
1 6 1
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdio>
using namespace std;
struct node
{
int x, y;
} p[1001];
bool op(const struct node &xx, const struct node &yy)
{
if (xx.x == yy.x)
return xx.y < yy.y;
else
return xx.x < yy.x;
}
int main()
{
int points;
while (scanf("%d", &points), points)
{
int sum = 0;
for (int i = 0; i < points; ++i)
scanf("%d%d", &p[i].x, &p[i].y);
sort(p, p + points, op);
for (int i = 0; i < points; ++i)
{
for (int j = i + 1; j < points; ++j)
{
//已知正方形两点的坐标(是正方形的一边),求另两点
//p[i]--p1,p[j]--p0
node p0, p1;
p0.x = p[i].x + p[j].y - p[i].y;
p0.y = p[i].y + p[i].x - p[j].x;
p1.x = p[j].x + p[j].y - p[i].y;
p1.y = p[j].y + p[i].x - p[j].x;
if (!binary_search(p, p+points, p0, op))
continue;
if (!binary_search(p, p+points, p1, op))
continue;
sum++;
}
}
printf("%d/n", sum / 2);//最后要除以2
}
return 0;
}