hdu 1013 Digital Roots 用一个大水题来纪念我进入杭电前一万名

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53090    Accepted Submission(s): 16577


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
   
   
   
   
24 39 0
 

Sample Output
   
   
   
   
6 3
哈哈,,本渣渣终于水到了一万名以内啦,排名是变了,,可渣的本质,,却依旧。废话不多说。
root(k)=k%9 如果k%9==0,则输出9,否则直接输出。
代码:
#include <stdio.h>
#include <string.h>
#define MAX 1000
int main()
{
	char str[MAX];
	while(scanf("%s",str)!=EOF)
	{
		if(strcmp("0",str) == 0)
		{
			return 0 ;
		}
		int sum = 0 ; 
		int len = strlen(str) ;
		for(int i = 0 ; i < len ; ++i)
		{
			sum += str[i]-'0' ;
		}
		if(sum%9==0)printf("9\n");
		else	printf("%d\n",sum%9) ;
	}
	return 0 ;
}

你可能感兴趣的:(ACM,水题,digital,Roots,hdu1013)