Description
“余”人国的国王想重新编制他的国家。他想把他的国家划分成若干个省,每个省都由他们王室联邦的一个成员来管理。他的国家有n个城市,编号为1..n。一些城市之间有道路相连,任意两个不同的城市之间有且仅有一条直接或间接的道路。为了防止管理太过分散,每个省至少要有B个城市,为了能有效的管理,每个省最多只有3B个城市。每个省必须有一个省会,这个省会可以位于省内,也可以在该省外。但是该省的任意一个城市到达省会所经过的道路上的城市(除了最后一个城市,即该省省会)都必须属于该省。一个城市可以作为多个省的省会。聪明的你快帮帮这个国王吧!
Input
第一行包含两个数N,B(1<=N<=1000, 1 <= B <= N)。接下来N-1行,每行描述一条边,包含两个数,即这条边连接的两个城市的编号。
Output
如果无法满足国王的要求,输出0。否则输出数K,表示你给出的划分方案中省的个数,编号为1..K。第二行输出N个数,第I个数表示编号为I的城市属于的省的编号,第三行输出K个数,表示这K个省的省会的城市编号,如果有多种方案,你可以输出任意一种。
Sample Input
8 2
1 2
2 3
1 8
8 7
8 6
4 6
6 5
Sample Output
3
2 1 1 3 3 3 3 2
2 1 8
这个题本质上就是一个DFS,这个省会可以位于省内,也可以在该省外,这个条件其实是多余的,因为如果省会在省外,总可以找到省内的省会。
#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
int n,K;
int map[1500][1500];
int mark[1500];
int bcnt[1500];
int num;
void print(){
int i,j;
printf("%d\n",num);
for(i=1; i<n; i++) printf("%d ",mark[i]);
printf("%d\n",mark[n]);
for(i=1; i<=num; i++)
for(j=1; j<=n; j++)
if(mark[j]==i){
printf("%d ",j);
break;
}
printf("\n");
}
void go(int root,int last){
int i;
if(mark[root]!=0)return;
mark[root]=num;
if(map[root][0]==1)
return;
for(i=1; i<=map[root][0]; i++)
if(map[root][i]!=last)
go(map[root][i],root);
}
void dfs(int root,int last)
{
if(map[root][0]==1){
bcnt[root]=1;
return;
}
int i;
for(i=1; i<=map[root][0]; i++)
if(map[root][i]!=last){
dfs(map[root][i],root);
bcnt[root]+=bcnt[map[root][i]];
}
bcnt[root]++;
if(bcnt[root]>=K && bcnt[root]<=3*K){
bcnt[root]=0;
num++;
go(root,last);
}
}
void work(){
int i,q,j;
for(i=1; i<=n; i++){
memset(bcnt,0,sizeof(bcnt));
memset(mark,0,sizeof(mark));
num=0;
dfs(i,0);
q=0;
for(j=1; j<=n; j++)
if(mark[j]!=0) q++;
if(q==n){
print();
return;
}
}
printf("0\n");
}
int main(){
scanf("%d%d",&n,&K);
int i,x,y,j;
for(i=1; i<=n-1; i++){
scanf("%d%d",&x,&y);
map[x][++map[x][0]]=y;
map[y][++map[y][0]]=x;
}
work();
return 0;
}