POJ2141(Message Decowding)

Message Decowding
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10890   Accepted: 6021

Description

The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:
        yrwhsoujgcxqbativndfezmlpk

Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

Input

* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded

Output

* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

Sample Input

eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj

Sample Output

Jump the fence when you seeing me coming

没什么说的,简单的水题!

//Accepted	176K	0MS	C++	686B	2013-04-15 16:15:42
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
const int N = 30;
char key[N];

bool is_upper(char x) {
    if(x>='A' && x <='Z') return true;
    return false;
}

bool is_lower(char y) {
    if(y>='a' && y<='z') return true;
    return false;
}

int main()
{
    char c;
    scanf("%s", key);
    getchar();
    while(scanf("%c", &c) != EOF) {
        if(is_lower(c)) printf("%c", key[c-'a']);
        else if(is_upper(c)) {
            char tmp = key[c-'A']-32;
            printf("%c", tmp);
        }
        else {
            printf("%c", c);
        }
    }
    return 0;
}
 

你可能感兴趣的:(POJ2141(Message Decowding))