IP Address
Time Limit: 1000MS |
|
Memory Limit: 30000K |
Total Submissions: 15540 |
|
Accepted: 8911 |
Description
Suppose you are reading byte streams from any device, representing IP addresses. Your task is to convert a 32 characters long sequence of '1s' and '0s' (bits) to a dotted decimal format. A dotted decimal format for an IP address is form by grouping 8 bits at a time and converting the binary representation to decimal representation. Any 8 bits is a valid part of an IP address. To convert binary numbers to decimal numbers remember that both are positional numerical systems, where the first 8 positions of the binary systems are:
27 26 25 24 23 22 21 20
128 64 32 16 8 4 2 1
Input
The input will have a number N (1<=N<=9) in its first line representing the number of streams to convert. N lines will follow.
Output
The output must have N lines with a doted decimal IP address. A dotted decimal IP address is formed by grouping 8 bit at the time and converting the binary representation to decimal representation.
Sample Input
4
00000000000000000000000000000000
00000011100000001111111111111111
11001011100001001110010110000000
01010000000100000000000000000001
Sample Output
0.0.0.0
3.128.255.255
203.132.229.128
80.16.0.1
Source
México and Central America 2004
对于N组数组,每个数据有32位。每8位决定一个数字,将这个32位转换成4个十进制数字,用'.'间隔。
用一个函数,参数为一个字符串,每次取其前八位,对于每一个位的数字进行判断,如果为1,则加上该位表示的数字。
代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>
char str[50];
int bin[10] = {128, 64, 32, 16, 8, 4, 2, 1};
int IPAddress(char str[]){
int sum = 0;
int i;
for (i = 0; i < 8; i++){
if (str[i] == '1'){
sum += bin[i];
}
}
return sum;
}
int main(void){
int casenum, ii;
scanf("%d", &casenum);
getchar();
for (ii = 0; ii < casenum ; ii++){
gets(str);
printf("%d.%d.%d.%d\n", IPAddress(str), IPAddress(str + 8), IPAddress(str + 16), IPAddress(str + 24));
}
return 0;
}