Ambiguous permutations
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 5245 |
|
Accepted: 3095 |
Description
Some programming contest problems are really tricky: not only do they require a different output format from what you might have expected, but also the sample output does not show the difference. For an example, let us look at permutations.
A permutation of the integers 1 to n is an ordering of these integers. So the natural way to represent a permutation is to list the integers in this order. With n = 5, a permutation might look like 2, 3, 4, 5, 1.
However, there is another possibility of representing a permutation: You create a list of numbers where the i-th number is the position of the integer i in the permutation. Let us call this second possibility an inverse permutation. The inverse permutation for the sequence above is 5, 1, 2, 3, 4.
An ambiguous permutation is a permutation which cannot be distinguished from its inverse permutation. The permutation 1, 4, 3, 2 for example is ambiguous, because its inverse permutation is the same. To get rid of such annoying sample test cases, you have to write a program which detects if a given permutation is ambiguous or not.
Input
The input contains several test cases.
The first line of each test case contains an integer n (1 <= n <= 100000). Then a permutation of the integers 1 to n follows in the next line. There is exactly one space character between consecutive integers. You can assume that every integer between 1 and n appears exactly once in the permutation.
The last test case is followed by a zero.
Output
For each test case output whether the permutation is ambiguous or not. Adhere to the format shown in the sample output.
Sample Input
4
1 4 3 2
5
2 3 4 5 1
1
1
0
Sample Output
ambiguous
not ambiguous
ambiguous
Hint
Huge input,scanf is recommended.
Source
Ulm Local 2005
对于一个有N个元素的队列,队列元素为[1,2,...,N-1,N],进行一次队列变换,当前队列“数字i的位置”将成为变换后队列的第i个元素的值(下标从1开始)。
一开始拿到题目基本上又是什么都没有读懂的状态,就知道又是讨厌的英文题了。。。搞懂题意之后简单模拟就可以出解。
代码(1AC):
#include <cstdio>
#include <cstdlib>
#include <cstring>
int arr[110000];
int end[110000];
int change(int arr[], int n){ //0 not ambiguous 1 ambiguous
int i, j;
int flag = 1;
for (i = 1; i <= n; i++){
end[arr[i]] = i;
}
for (i = 1; i <= n; i++){
if (end[i] != arr[i]){
flag = 0;
}
}
return flag;
}
int main(void){
int n, i;
while (scanf("%d", &n), n != 0){
memset(arr, 0, sizeof(arr));
memset(end, 0, sizeof(end));
for (i = 1; i <= n; i++){
scanf("%d", &arr[i]);
}
if (change(arr, n)){
printf("ambiguous\n");
}
else{
printf("not ambiguous\n");
}
}
return 0;
}