Milk hdu 1070

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=1070


题目描述:

Milk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10110    Accepted Submission(s): 2394


Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
 

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
 

Sample Input
   
   
   
   
2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
 

Sample Output
   
   
   
   
Mengniu Mengniu
Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.




题意:

喝牛奶 的三个条件 

1. 喝同一瓶牛奶不能超过5天

2.不喝200ml以下的

求最便宜的 ,若最便宜的不止一个,选最多的。


题解:

贪心排序

按平均每天消费和总容量的比较来排序

平均每天消费=价格/天数  ; 天数=总容量/200;



代码:

/*
hackerwin7
hdu:Milk
*/
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<string.h>
#define NUM 200
#define INF 999999999
using namespace std;

int T=0;//number of cases
int N=0;//the number of the milk
typedef struct Milk
{
	char Brand[100+5];
	int P;
	int V;
	int Days;
	int AverageP;
	Milk()
	{
		memset(Brand,'\0',sizeof(Brand));
		P=V=Days=AverageP=0;
	}
}Milk;
Milk Milks[100+5];

/*compare for the sort,A>B is true them A is in front of B*/
bool cmp(Milk A,Milk B)
{
	if(A.AverageP!=B.AverageP)
	{
		return(A.AverageP<B.AverageP);
	}
	return(A.V>B.V);
}

/*for test*/
int test()
{
	return(0);
}

/*main process*/
int MainProc()
{
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&N);
		int i=0;
		for(i=0;i<=N-1;i++)
		{
			scanf("%s%d%d",Milks[i].Brand,&Milks[i].P,&Milks[i].V);
			Milks[i].Days=Milks[i].V/NUM;
			if(Milks[i].Days>5)
			{
				Milks[i].Days=5;
			}
			if(Milks[i].Days==0)
			{
				Milks[i].AverageP=INF;
			}
			else
			{
				Milks[i].AverageP=Milks[i].P/Milks[i].Days;
			}
		}
		sort(Milks,Milks+N,cmp);
		printf("%s\n",Milks[0].Brand);
	}
	return(0);
}

int main()
{
	MainProc();
	return(0);
}





你可能感兴趣的:(Milk hdu 1070)