uva 1423 - Guess(拓扑排序)

Given a sequence of integers, a1, a2,..., an , we define its sign matrix S such that, for 1ijn , Sij = `` + " if Sij = `` - " if ai +...+ aj < 0 ; and Sij = ``0" otherwise.

For example, if (a1, a2, a3, a4) = (- 1, 5, - 4, 2) , then its sign matrix S is a 4×4 matrix:


  1 2 3 4
1 - + 0 +
2   + + +
3     - -
4       +


We say that the sequence (-1, 5, -4, 2) generates the sign matrix. A sign matrix is valid if it can be generated by a sequence of integers.

Given a sequence of integers, it is easy to compute its sign matrix. This problem is about the opposite direction: Given a valid sign matrix, find a sequence of integers that generates the sign matrix. Note that two or more different sequences of integers can generate the same sign matrix. For example, the sequence (-2, 5, -3, 1) generates the same sign matrix as the sequence (-1,5, -4,2).

Write a program that, given a valid sign matrix, can find a sequence of integers that generates the sign matrix. You may assume that every integer in a sequence is between -10 and 10, both inclusive.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case consists of two lines. The first line contains an integer n (1n10) , where n is the length of a sequence of integers. The second line contains a string of n(n + 1)/2 characters such that the first n characters correspond to the first row of the sign matrix, the next n - 1 characters to the second row, ... , and the last character to the n -th row.

Output

Your program is to write to standard output. For each test case, output exactly one line containing a sequence of n integers which generates the sign matrix. If more than one sequence generates the sign matrix, you may output any one of them. Every integer in the sequence must be between -10 and 10, both inclusive.

Sample Input

3 
4 
-+0++++--+ 
2 
+++ 
5 
++0+-+-+--+-+--

Sample Output

-2 5 -3 1 
3 4 
1 2 -3 4 -5

这道题很容易转化成:
已知s[0],s[1]...s[n]的大小关系,求a[1],a[2]...a[n]的值
不要想直接转化得到数列a的大小关系,那样不好找。而已知s后,可以直接用s[n]-s[n-1]求a[n];
并且只要让相邻的s相差为1,a的值的绝对值就不会超过10.
然后拓扑排序时先找到所有入度为0的点后,再进行“减度”。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n;
int const maxn = 10 + 5;

int degree[maxn];
int map[maxn][maxn];
int s[maxn],ans[maxn];
char text[1000];

void init(){
    memset(map,0,sizeof(map));
    memset(degree,0,sizeof(degree));
}

void topsort(){
    int count = 0,low = -10;
    while(count != n+1){
        int tag[maxn];
        memset(tag,0,sizeof(tag));
        for(int i = 0;i <= n;i++){
            if(degree[i] == 0){
                s[i] = low;
                degree[i] = -1;
                tag[i] = 1;
                count++;
            }
        }
        low++;
        for(int i = 0;i <= n;i++){
            if(tag[i]){
                for(int j = 0;j <= n;j++){
                    if(map[i][j])
                        degree[j]--;
                }
            }
        }
    }
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d%s",&n,text);
        init();
        char f;
        int idx = 0;
        for(int i = 1;i <= n;i++){
            for(int j = i;j <= n;j++){
                f = text[idx++];
                if(f == '+'){
                    map[i-1][j] = 1;
                    degree[j]++;
                }
                else if(f == '-'){
                    map[j][i-1] = 1;
                    degree[i-1]++;
                }
            }
        }
        topsort();
        for(int i = 1;i <= n;i++){
            ans[i] = s[i] - s[i-1];
        }
        for(int i = 1;i < n;i++)
            printf("%d ",ans[i]);
        printf("%d\n",ans[n]);
    }
    return 0;
}


 

你可能感兴趣的:(uva 1423 - Guess(拓扑排序))