hdu 1342 Lotto

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1342

题目描述:

Lotto

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1503    Accepted Submission(s): 745


Problem Description
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34]. 

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k. 
 

Output
For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case. 
 

Sample Input
   
   
   
   
7 1 2 3 4 5 6 7 8 1 2 3 5 8 13 21 34 0
 

Sample Output
   
   
   
   
1 2 3 4 5 6 1 2 3 4 5 7 1 2 3 4 6 7 1 2 3 5 6 7 1 2 4 5 6 7 1 3 4 5 6 7 2 3 4 5 6 7 1 2 3 5 8 13 1 2 3 5 8 21 1 2 3 5 8 34 1 2 3 5 13 21 1 2 3 5 13 34 1 2 3 5 21 34 1 2 3 8 13 21 1 2 3 8 13 34 1 2 3 8 21 34 1 2 3 13 21 34 1 2 5 8 13 21 1 2 5 8 13 34 1 2 5 8 21 34 1 2 5 13 21 34 1 2 8 13 21 34 1 3 5 8 13 21 1 3 5 8 13 34 1 3 5 8 21 34 1 3 5 13 21 34 1 3 8 13 21 34 1 5 8 13 21 34 2 3 5 8 13 21 2 3 5 8 13 34 2 3 5 8 21 34 2 3 5 13 21 34 2 3 8 13 21 34 2 5 8 13 21 34 3 5 8 13 21 34

题意:

排列组合

题解:

DFS,后序递归神搜。注意前序递归,后序递归,中序递归的不同处理顺序与处理模式。

代码:

#include<stdio.h>
int k=0,cases=0;//length
int S[20],sub[10];
//dfs the S array
int  DFS(int S_cur,int sub_cur)
{
    if(sub_cur>=6)
    {
        printf("%d",sub[0]);
        for(int i=1;i<=6-1;i++) printf(" %d",sub[i]);
        printf("\n");
    }
    else
    {
        if(S_cur>=k) return(0);
        sub[sub_cur]=S[S_cur];
        DFS(S_cur+1,sub_cur+1);//selected elem into sub
        DFS(S_cur+1,sub_cur);//not selected
    }
    return(0);
}
int main()
{
    while(scanf("%d",&k)!=EOF&&k>0)
    {
        if(cases++) printf("\n");
        for(int i=0;i<=k-1;i++) scanf("%d",&S[i]);
        DFS(0,0);//dfs the S array to select element into sub array
    }
    return(0);
}



你可能感兴趣的:(递归)