[模拟]All in All uva10340

Problem E

All in All

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input Specification

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source: ULM Local Contest

 

题意:给你2个字串s,t,请你写一个程式判断是否s是t的子字串。

很水的一道题么了,直接模拟就行了。

#include<iostream>
#include<string>

using namespace std;

int main()
{
    string str1,str2;
    while(cin>>str1>>str2)
    {
        int i,k=0;
        for(i=0;i<str2.size();i++)
        {
            if(str2[i]==str1[k]) k++;
        }
        if(k==str1.size()) cout<<"Yes"<<endl;
        else cout<<"No"<<endl;
    }
    return 0;
}


你可能感兴趣的:(模拟)