hdoj 2102 A计划 【BFS】

A计划

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13232    Accepted Submission(s): 3262


Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
 

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
 

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
 

Sample Input
   
   
   
   
1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..
 

Sample Output
   
   
   
   
YES
 

思路:注意每次搜索到#的处理,若另一层的对应位置是#或者*就不能传送,反之可以传送。 其它并没有什么, 就是裸BFS 。


AC代码:

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
struct Node
{
    int x, y, z, step;
    friend bool operator < (Node a, Node b)
    {
        return a.step > b.step;
    }
};
int N, M, T;
char Map[2][12][12];
bool vis[2][12][12];
void getMap()
{
    for(int i = 0; i < 2; i++)
    {
        for(int j = 0; j < N; j++)
            scanf("%s", Map[i][j]);
        getchar();
    }
}
bool judge(Node a)
{
    return a.x >= 0 && a.x < 2 && a.y >= 0 && a.y < N && a.z >= 0 && a.z < M && !vis[a.x][a.y][a.z] && Map[a.x][a.y][a.z] != '*';
}
void BFS(int x, int y, int z)
{
    priority_queue<Node> Q;
    Node now, next;
    bool flag = false;
    memset(vis, false, sizeof(vis));
    int move[4][2] = {0,1, 0,-1, 1,0, -1,0};
    now.x = now.y = now.z = now.step = 0;
    Q.push(now);
    vis[0][0][0] = true;
    while(!Q.empty())
    {
        now = Q.top();
        Q.pop();
        if(Map[now.x][now.y][now.z] == 'P')
        {
            if(now.step <= T)
                flag = true;
            break;
        }
        if(Map[now.x][now.y][now.z] == '#')
        {
            next.x = 1 - now.x;
            next.y = now.y;
            next.z = now.z;
            next.step = now.step;
            if(judge(next) && Map[next.x][next.y][next.z] != '#')
                 vis[next.x][next.y][next.z] = true, Q.push(next);
        }
        else
        {
            for(int k = 0; k < 4; k++)
            {
                next.x = now.x;
                next.y = now.y + move[k][0];
                next.z = now.z + move[k][1];
                next.step = now.step + 1;
                if(judge(next))
                    vis[next.x][next.y][next.z] = true, Q.push(next);
            }
        }
    }
    if(flag)
        printf("YES\n");
    else
        printf("NO\n");
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d%d", &N, &M, &T);
        getMap();
        BFS(0, 0, 0);
    }
    return 0;
}


你可能感兴趣的:(hdoj 2102 A计划 【BFS】)