stack&&UVa514 Rails (铁轨)的理解与解析

stack&&UVa514 Rails (铁轨)的理解与解析
stack&&UVa514 Rails(ACM/ICPC CERC 1997)  (铁轨)。




  Rails 

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.


 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has  coaches numbered in increasing order . The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be . Help him and write a program that decides whether it is possible to get the required order of coaches(判断是否能让它们按照某种特定的顺序(chief给出的顺序)进入B方向的铁轨). You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input 

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer  N  described above. In each of the next lines of the block there is a permutation of   The last line of the block contains just 0.

The last block consists of just one line containing 0.

Output 

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains  Yes  if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains  No . In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

Sample Input 

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output 

Yes
No

Yes

Solution

解决方法来自书上,这里根据自己的理解加了注释。
#include <iostream>
#include <cstdio>
#include <stack>
using namespace std;
const int MAXN=1000+10;

int n,target[MAXN];

int main()
{
    while(scanf("%d",&n)==1){
        stack<int> s;
        int A=1,B=1;
        for(int i=1;i<=n;i++)
            scanf("%d",&target[i]);
        int ok=1;              //用来控制,并返回程序的执行情况
        while(B<=n){           //通过这里出去是正常的
            if(A==target[B]) {A++;B++;}  //相当于直接入栈出栈,就是直接经过一下C站就直接过去了                                  
            //只有在有相等的时候

            //肯定是有顺序(1~n)的进入,
            //有些符合的就是直接出栈,有些要等一下再出栈

            else if(!s.empty()&&s.top()==target[B]) {s.pop();B++;}//处理完以后到这里的时候,发现栈顶符合就出栈了              
            //才会有B++的
            else if(A<=n) s.push(A++);//不符合当然入栈喽,直到 末端封顶 ,到下面这个      
            //在这里执行的时间可能会比较多,如果连这里也满足不了的话,到下面就跳出去了,也就是No了
            else {ok=0; break;}  //如果这里出去就No了
        }
        printf("%s\n",ok ? "Yes" : "No");
    }
    return 0;
}

谢谢

你可能感兴趣的:(数据结构,栈,ACM,ICPC,uva)