UVA - 133 The Dole Queue

The Dole Queue
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

 4  8,  9  5,  3  1,  2  6,  10,  7

where  represents a space.

约瑟夫问题。
用数组a标记,0既为离开队伍的,数数时跳过。

#include<iostream>
#include<iomanip>
using namespace std;

const int MAXN = 25;
int n, a[MAXN];

int go(int p, int d, int t)            //p是报数开始的前一个位置,第一次报数时即n(正数)和1(倒数)。
{                                      //抽象出步长d的参数,把正数(1)与倒数(-1)两个go统一。t是步数
	while (t--)
	{
		do
		{ p = (p + d + n -1 ) % n + 1; }   //一开始走到报数的第一个数。
		while (a[p] == 0);                 //走到下一个非0数字。
	}
	return p;                              //返回要离开的数
}

int main()
{
	int k, m;
	while (cin >> n >> k >> m&&n)
	{
		for (int i = 1; i <= n; i++)
			a[i] = i;
		int left = n;                        //left记录剩下的有多少个。
		int p1 = n, p2 = 1;                  //注意,如上所说的。
		while (left)
		{
			p1 = go(p1, 1, k);
			p2 = go(p2, -1, m);
			if (p1 == p2)                    //区分两种情况。
			{
				cout<<setw(3) << p1;
				
				a[p1] =a[p2]= 0;
				left--;
			}
			else
			{
				cout << setw(3) << p1;
				cout << setw(3) << p2;
				
				a[p1] = a[p2] = 0;
				left--;
				left--;
			}
			if (left)
				cout << ',';
		}
		cout << endl;
	}
}


你可能感兴趣的:(UVA - 133 The Dole Queue)