1070. Mooncake (25)

题目:

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45
注意:
1、刚开始没有完全理解题意,亦或者题目没有把意思讲明白。
2、这里应该是已知不同mooncake的各自总量以及对应总量的总利润,然后让我们在一定市场需求量的条件下寻找一种使得利润最大的选择方案。
3、所以其实问题还是很简单的,先计算出每种mooncake的单个利润,并依此排序,每次都选择剩下的品种中单个利润最大的,知道达到市场需求量。

代码:
//1070
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

struct mooncake
{
	float amount;//
	float price;//total profit of this kind of mooncake
	float single;//single profit of this kind of mooncake
	bool operator > (const mooncake &m)const
	{
		return single>m.single;
	}
};
int main()
{
	vector<mooncake>cakes;
	int n,m;
	scanf("%d%d",&n,&m);
	cakes.resize(n);
	for(int i=0;i<n;++i)
		scanf("%f",&cakes[i].amount);
	for(int i=0;i<n;++i)
	{
		scanf("%f",&cakes[i].price);
		cakes[i].single=cakes[i].price/cakes[i].amount;
	}
	sort(cakes.begin(),cakes.end(),greater<mooncake>());
	float curamount=0.0;//current amount of mooncake we have calculated
	float profit=0.0;//the total profit
	int i=0;
	while(i<n)
	{
		if(curamount+cakes[i].amount<m)
		{
			curamount += cakes[i].amount;
			profit += cakes[i].price;
			++i;
		}
		else
		{
			profit += (m-curamount)*cakes[i].single;
			break;
		}
	}
	printf("%.2f\n",profit);
	return 0;
}


你可能感兴趣的:(考试,pat,浙江大学)