HDU2084 数塔 poj1163The Triangle


标题所述的两题题目虽有点不同,但代码是一样的。简单DP。


杭电原题链接

数塔

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29282    Accepted Submission(s): 17566


Problem Description
在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的:

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少?
HDU2084 数塔 poj1163The Triangle_第1张图片
已经告诉你了,这是个DP的题目,你能AC吗?
 

Input
输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。
 

Output
对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。
 

Sample Input
   
   
   
   
1 5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
 

Sample Output
   
   
   
   
30
 
poj原题链接
The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 41719   Accepted: 25233

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30


附上代码

#include <stdio.h>
int main()
{
    int a[105][105];
    int i,j,n;
    while(scanf("%d",&n)!=EOF)
    {
        for (i=0; i<n; i++)
        {
            for (j=0; j<=i; j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for (i=n-2; i>=0; i--)
        {
            for (j=0; j<=i; j++)
            {
                if(a[i+1][j]>a[i+1][j+1])
                {
                    a[i][j]+=a[i+1][j];
                }
                else
                {
                    a[i][j]+=a[i+1][j+1];
                }
            }
        }
        printf("%d\n",a[0][0]);
    }

    return 0;
}



你可能感兴趣的:(dp,poj,杭电,HDU杭电2084,数塔,北大poj1)