1057. Stack (30)【栈+树状数组】——PAT (Advanced Level) Practise

题目信息

1057. Stack (30)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian
where key is a positive integer no more than 10^5.

Output Specification:

For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print “Invalid” instead.

Sample Input:
17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop
Sample Output:
Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

解题思路

vector维护stack,排序或nth_element均会超时,此处用树状数组维护个数,a[i]记录值不大于i 的数共几个,进而二分找出中间值,

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int n, t;
int a[100005];
vector<int> vec;
inline int lowbit(int p){
    return p & (-p);
}
void add(int p, int v){
    while (p <= 100000){
        a[p] += v;
        p += lowbit(p);
    }
}
int sum(int p){
    int s = 0;
    while (p >= 1){
        s += a[p];
        p -= lowbit(p);
    }
    return s;
}
int find(int num){
    int b = 0, e = 100000, m;
    while (b < e){
        m = (b + e)/2;
        if (sum(m) >= num){
            e = m;
        }else{
            b = m + 1;
        }
    }
    return e;
}
int main()
{
    char s[20];
    scanf("%d", &n);
    while (n--){
        scanf("%s", s);
        if (s[1] == 'o'){
            if (vec.size() == 0){
                printf("Invalid\n");
            }else{
                add(vec[vec.size() - 1], -1);
                printf("%d\n", vec[vec.size() - 1]);
                vec.pop_back();
            }
        }else if (s[1] == 'u'){
            scanf("%d", &t);
            vec.push_back(t);
            add(t, 1);
        }else if (s[1] == 'e'){
            if (vec.size() == 0){
                printf("Invalid\n");
            }else{
                t = find((vec.size() + 1)/2);
                printf("%d\n", t);
            }
        }
    }
    return 0;
}

你可能感兴趣的:(栈,树状数组,pat,1057)