最短路径_Til the Cows Come Home (Poj 2387)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.


题意:给你n个点、m个双向边.问从第1到n的最短路径.

注意:这道题有重边,如果用Dijkstra算法要考虑重边,SPFA和Bellman_ford可以忽略.



样例代码:

#include <stdio.h>
#include <string.h>
#define INF 99999999
int mpt[1010][1010];
int dis[1010];
int visit[1010];

void Dijkstra(int x,int n)
{
    int i,j;
    for(i = 1; i <= n ; i ++)
        dis[i] = mpt[x][i];
    memset(visit,0,sizeof(visit));
    visit[x] = 1;
    for(i = 1; i < n ; i ++)
    {
        int Minj = -1,Min = INF;
        for(j = 1; j <= n ; j ++)
        {
            if(visit[j]) continue;
            if( Min > dis[j])
            {
                Min = dis[j];
                Minj = j;
            }
        }
        if(Minj == -1)continue;
        visit[Minj] = 1;
        for(j = 1; j <= n ; j ++)
        {
            if(dis[j] > dis[Minj]+mpt[Minj][j] ) dis[j] = dis[Minj]+mpt[Minj][j];
        }
    }
}
int main()
{
	int n,m,i,j;
	while(scanf("%d %d",&m,&n)!=EOF)
	{
		int v,u,len;
		for(i = 1; i <= n ; i ++)
		{
			for(j = 1; j <= n ; j ++)
			{
				if( i == j ) mpt[i][j] = 0;
				else mpt[i][j] = INF;
			}
		}
		for(i = 0 ; i < m ; i ++)
		{
			scanf("%d %d %d",&u,&v,&len);
			if(mpt[u][v] > len) mpt[u][v] = len,mpt[v][u] = len;
		}
		Dijkstra(1,n);
		printf("%d\n",dis[n]);
	}
	return 0;
}





你可能感兴趣的:(最短路径,dijkstra)