hdu 4006 The kth great number

hdu 4006 的传送门->

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an ” I” followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

题目大意: 就是I表示增加一个数,Q表示输出第k大的数,

解题思路:就是用set 简单搞一下就好了。。。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <set>
using namespace std;
//注意啦!!!!
multiset <int> s;//注意这里是multiset,是有重复的
multiset <int> ::iterator it;
char st[2];
int main()
{
    int m,k,x;
    while(~scanf("%d%d",&m,&k))
    {
        s.clear();
        while(m--)
        {
            scanf("%s",st);
            if(st[0] == 'I')
            {
                scanf("%d",&x);
                s.insert(x);
                if(s.size()>k)
                    s.erase(s.begin());
            }
            else
            {
                it=s.begin();
                printf("%d\n",*it);
            }
        }
    }
    return 0;
}

你可能感兴趣的:(set,STL)